Lepton Maker Community / Forum / General discussion / Topics / 16-bit TLinear data fluctuation issue

16-bit TLinear data fluctuation issue

Home Lepton and Windows Forums Lepton maker community General discussion 16-bit TLinear data fluctuation issue

Tagged: 

This topic contains 4 replies, has 4 voices, and was last updated by Profile photo of Rosh Rosh 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)

  • Author

    Posts

  • #12523

    Profile photo of Hung
    Hung

    Participant

    Hi all,
    I’m currently conducting a face temperature measurement experiment with FLIR Lepton 3.5 Cam on Purethermal 2. I got an issue when trying to extract the temperature value of my face, the temperature values of every pixel increases ~1 degC and fall back slowly after.

    read-in data fluctuation

    Experiment setup description:
    4-minute cycle:br
    1 minute idle (fake face, wrong temperature) + FFC performancebr (at sample 540)
    1 more minute idlebr
    1 minute showing real face (human temperature): samples 1100-1700br
    idles till end

    – The camera produced strange data when I came into the capturing scene (at around 1100th sample), every read-in values (hottest temp. – cyan, hot reference black body temp. – red pointed line, cool reference temp. – blue pointed line, and forehead temp. – black dotted line) increases approx. 1 degC and slowly fall back after a period of ~200 samples.br

    – I wonder what causes the whole frame’s data to rise up like that, and if there’s any method to avoid that effect?FYI, I use TLinear mode to extract raw 16-bit data, below are my detailed settings:

    LEP_GetAgcCalcEnableState LEP_AGC_DISABLEbr
    LEP_GetRadEnableState LEP_RAD_ENABLEbr
    LEP_GetRadTShutterMode LEP_RAD_TS_FIXED_MODEbr
    LEP_GetRadTLinearEnableState LEP_RAD_ENABLEbr
    LEP_GetRadTLinearAutoResolution LEP_RAD_DISABLEbr
    Radiometric spotmeterRoi 59 79 60 80br
    LEP_GetOemVideoOutputEnable LEP_VIDEO_OUTPUT_DISABLEbr
    LEP_GetVidSbNucEnableState LEP_VID_SBNUC_DISABLEbr
    LEP_GetSysGainMode LEP_SYS_GAIN_MODE_HIGHbr
    LEP_GetSysTelemetryEnableState 0

    Thank you for helping.
    Best regards,
    Hung

    • This topic was modified 1 year, 10 months ago by Profile photo of Hung Hung.
    • This topic was modified 1 year, 10 months ago by Profile photo of Hung Hung.
    • This topic was modified 1 year, 10 months ago by Profile photo of Hung Hung.

    #12531

    Profile photo of Gavin
    Gavin

    Moderator

    Hey Hung,

    Sorry for the delay, I’m currently researching your issue and will try to get back to you with an answer in 2-3 days.

    Thank you,
    Gavin
    FLIR Community Support

    • This reply was modified 1 year, 10 months ago by Profile photo of Gavin Gavin.
    • This reply was modified 1 year, 10 months ago by Profile photo of Gavin Gavin.

    #12542

    Profile photo of Hung
    Hung

    Participant

    Hi Gavin,

    It’s great to hear from you.

    If you need more information from my side, just let me know.

    Thank you for your help,
    Hung

    #16361

    Profile photo of Gregor
    Gregor

    Participant

    Hi Gavin, Hung,

    I am also interested in this issue. Do you have a hint on what could cause this rise and exponential cool-down?

    Best,
    Gregor

    #18393

    Profile photo of Rosh
    Rosh

    Participant

    I was wondering if there is an answer to this issue. I’m having the same problem and cannot fix it however I try. The fluctuation happens at the time of each FFC and lasts for some seconds.
    I really appreciate your help with this.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.