Lepton Maker Community / Forum / Installation and getting started / Topics / Error in getting image (red square on image)

Error in getting image (red square on image)

Home Lepton and Windows Forums Raspberry Pi development Installation and getting started Error in getting image (red square on image)

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of Eduardo Eduardo 2 months, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)

  • Author

    Posts

  • #18459

    Profile photo of Eduardo
    Eduardo

    Participant

    Hello,

    I cannot get image stream, only a red square on a black backgorund. I am using a Raspberry Pi 3 B, Breakout Board v2.0 and Lepton 3.5. I know this is a known issue, but I have not found any solution to this problem, that is the reason I am posting this, to know if anyone got a solution for it.

    I am following this: https://github.com/groupgets/LeptonModule
    When I run sudo ./raspberrypi_video -tl 3 I got a red square with black background
    When I run sudo ./raspberrypi_qt I got a full red square

    What I have tried:
    – Changing the CS0 to CS1 (pin 24 to pin 26). Nothing changed
    – Removing and put back in the sensor in the breakout board. Nothing changed
    – Removing the VDD from breakout board while everything was running. Nothing changed
    – Already checked the connections and the supply voltage in breakout board. All is ok

    Anyone have a solution for this problem? Or any other ideas?

    #18460

    Profile photo of Eduardo
    Eduardo

    Participant

    Update: How I make it “work”.

    Added this line: fprintf(stdout, "\n"); above if(resets == 750) { into LeptonThread.cpp:
    and added #include <sdtio.h> in the file

    //Note: we've selected 750 resets as an arbitrary limit, since there should never be 750 "null" packets between two valid transmissions at the current poll rate
    //By polling faster, developers may easily exceed this count, and the down period between frames may then be flagged as a loss of sync
            # ADD HERE
            fprintf(stdout, "\n");
    	if(resets == 750) {
    		SpiClosePort(0);
    		lepton_reboot();
    		n_wrong_segment = 0;
    		n_zero_value_drop_frame = 0;
    		usleep(750000);
    		SpiOpenPort(0, spiSpeed);
    		}
    	continue;
    

    It’s not beutifull nor a final solution, but worked for me.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.