Lepton Maker Community / Forum / Installation and getting started / Topics / Recording and Viewing Raw Data

Recording and Viewing Raw Data

This topic contains 29 replies, has 16 voices, and was last updated by Profile photo of KaSaBiS KaSaBiS 1 month, 3 weeks ago.

Viewing 10 posts - 21 through 30 (of 30 total)

  • Author

    Posts

  • #16108

    Profile photo of Ziteng
    Ziteng

    Participant

    I tried to run the program both with the script and manually. But I cannot display the image at all. On the terminal, I got the error message “MESA-LOADER: failed to retrieve device information”. I assume that this is because it’s not getting USB permissions. I’ve tried to type the line for the USB permissions in the terminal several times and still got the same result. Can you give me some ideas about what went wrong, please?

    #16109

    Profile photo of Ziteng
    Ziteng

    Participant

    In the terminal, I got message of “uvc open error, Failed to open device”

    #16123

    Profile photo of Ting
    Ting

    Participant

    Thanks Karl for your message.
    I success use the following the repository: https://github.com/Kheirlb/purethermal1-uvc-capture.
    But how do get the current max temp value? Save it.

    Thank you,
    Ting

    #16333

    Profile photo of xiangrui
    xiangrui

    Participant

    Hi Karl

    We are using your codes with a Lepton3.5 on PureThermal 2 connected to Raspberry pi 4 and ran the file recordIR_v18.3.py
    However, the error popped up after we clicked ” Start IR Camera Feed” : uvc_start_streaming failed : -99, Failed to open device.

    Can you help ?

    Thanks

    #16344

    Profile photo of Vivek
    Vivek

    Participant

    Hi Cheou,

    Have you figured it out how to get raw footage using c++ sdk? Can you share you progress?

    #16348

    Profile photo of JimAt
    JimAt

    Participant

    After all the setup, finally, I can run the program, but always reported following error:</p>
    <p>qrc:/lepton/VidControls.qml:125: TypeError: Cannot read property ‘data’ of undefined<br />
    qrc:/lepton/VidControls.qml:143: TypeError: Cannot read property ‘data’ of undefined<br />
    qrc:/lepton/VidControls.qml:149: TypeError: Cannot read property ‘data’ of undefined<br />
    qrc:/lepton/AgcControls.qml:257: TypeError: Cannot read property ‘data’ of undefined<br />
    qrc:/lepton/AgcControls.qml:263: TypeError: Cannot read property ‘data’ of undefined</p>
    <p>Seems to me the device have some problem, annyone can help this ?

    • This reply was modified 11 months, 2 weeks ago by Profile photo of JimAt JimAt.

    #16370

    Profile photo of JimAt
    JimAt

    Participant

    I installed Windows program, connected camera with USB, after launched progrma, I cannot see CCI have anything shown there, status : yellow disconnected, how to enable CCI ?

    #16393

    Profile photo of Nathan
    Nathan

    Participant

    Okay question for the forums here.

    I’m new to lepton programming. I have here the pure thermal device which hooks up to the USB. I’m looking to read temperature from the camera and display the feed and through some research and trial and error, worked out that in order to read temperature it would have to be raw data. The system is running on a raspberrypi intending to run headless.

    Previously I had been using opencv to get data from the thermal camera and displaying, but this didn’t get temperature readings. I’ve inspected the code and tailored it to what I need. However the camera on the libuvc end is saying uvc_open error.

    I’ve looked at this article:
    https://github.com/groupgets/purethermal1-uvc-capture/issues/7
    however the camera has permissions for normal users to access (sudo does not work)

    Unique constraint of the system is that we’re running two cameras, one mjpeg camera and the pure thermal camera.Firstly, I’ve noticed that libuvc has the ability to read mjpeg frames, however there doesn’t seem to be any forum for libuvc OR google group. The documentation site for libuvc is down also (atleast, I can’t seem to load it) This complicates matters. Currently with the installation of libuvc I do not read mjpeg frames – the example doesn’t give any example to running mjpeg.

    Anyone have any experience getting mjpeg frames for libuvc? I know this is a stretch but i’m at the moment out of options.
    Also, any help with opening the thermal camera using libuvc would be appreciated. Is libuvc my only option for reading temperature data from the camera with python?

    #18469

    Profile photo of Andy
    Andy

    Participant

    Hello Karl,

    Thank you for the awesome program that you shared.

    I have two questions for you.

    1. Can I adjust the temperature range (Max and min) of each frame in the post processing window?

    2. I am having trouble to import the .tiff file into the MATLAB, do you have any document or suggestion?

    Thank you,

    #18472

    Profile photo of KaSaBiS
    KaSaBiS

    Participant

    stumped. Is there a variable I can change for this to work with my 1.4v camera?

    The camera is recognized and works with /raspberrypi_video but recordIR_v18.3 errors and says it cannot connect to camera, and to plug/replug and wait 10 seconds.

    that nor rebooting has solved it. I am wondering if it just does not recognize/suppport the older model

Viewing 10 posts - 21 through 30 (of 30 total)

You must be logged in to reply to this topic.