Lepton Maker Community / Forum / Installation and getting started / Topics / Shutter closes/opens on power on

Shutter closes/opens on power on

This topic contains 6 replies, has 4 voices, and was last updated by Profile photo of Elset Elset 8 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)

  • Author

    Posts

  • #11867

    Profile photo of Rasmus
    Rasmus

    Participant

    Hi,
    I just got a flir lepton 3.5 camera with a breakout board.

    I have wired everything according to the forum and manual for the breakout,but when I power up the module, it continuously open and closes the shutter with a ~3 seconds interval.

    Any clue why this is happening?

    I cannot seem to get any of the software working either.

    #11868

    Profile photo of Rasmus
    Rasmus

    Participant

    I’m using a raspberry pi 3.
    SPI and I2C has been enabled
    … and I’m using the following wire setup:

    CS -> Pin 24, CE0
    MOSI -> Pin 19, MOSI
    MISO -> Pin 21, MISO
    CLK -> Pin 23, CLK
    GND -> Pin 25, GND
    VIN -> Pin 1, 3V3
    SDA -> Pin 3, SDA
    SCL -> Pin 5, SCL
    • This reply was modified 2 years, 4 months ago by Profile photo of Rasmus Rasmus.
    • This reply was modified 2 years, 4 months ago by Profile photo of Rasmus Rasmus.

    #11871

    Profile photo of Rasmus
    Rasmus

    Participant

    It seems it’s doing a FCC over and over again.

    Any clues on why this is happening?

    #11875

    Profile photo of Allison
    Allison

    Moderator

    Hi Rasmus,

    My best guess would either be a power issue or a defective component. When the lepton powers on the lens should open and close as it performs an initial FFC then it will continue to perform FFCs at regular intervals (the default is about every 3 mins) however, there should be decent spacing between them. If it is continually performing FCCs it could be a power issue where it is receiving a fluctuating level of power and thus turning off and on again. However, it seems more likely it is getting a false signal to perform an FCC. I would double check all wiring and also that no program is running on the Raspberry Pi that could be sending anything over I2C. If wiring is correct and power is not an issue, unfortunately, it is likely one of the components is faulty.

    If you want to try running software to see if it may work anyways. These are some repositories that I’ve seen work for others:
    https://github.com/novacoast/Lepton-3-Module
    https://github.com/TradeCrafter/lepton3
    https://github.com/groupgets/pylepton/tree/lepton3-dev

    Thank you,
    Allison Torchia

    #11878

    Profile photo of Rasmus
    Rasmus

    Participant

    Hi Allison,
    Thanks a lot for the reply.
    In the end I had a loose connection, making the camera restart over and over.
    Thanks for the github repos!
    Best regards,
    Rasmus

    #16271

    Profile photo of David
    David

    Participant

    I am having a similar problem. I am using the Lepton 3 with Raspberry Pi 4. I have it wired the same way as Rasmus does above although for some reason the breakout board it came with from GroupGets has 2 SCL’s. In this case the first SCL which is next to VIN I have connected to SDA. Nothing else is connected to the Pi, none of the wires are loose.

    When the camera starts up I get the shutter open and close sequence for about 5 cycles and at the end of the close there is a high pitch noise that lasts until the open cycle. Then there is a long high pitched noise for a few seconds. Is this normal???

    Then I run raspberrypi_video -tl 3 and I get the red square in the top left

    When I run the following code I get what looks like a corrupted image with lots of horizontal grey lines. Sometimes when I run the code it hangs on the l.capture()

    import numpy as np
    import cv2
    from pylepton import Lepton

    with Lepton() as l:
    a,_ = l.capture()
    cv2.normalize(a, a, 0, 65535, cv2.NORM_MINMAX) # extend contrast
    np.right_shift(a, 8, a) # fit data into 8 bits
    cv2.imwrite(“output.jpg”, np.uint8(a)) # write it!

    #16516

    Profile photo of Elset
    Elset

    Participant

    Hello…based on my experience i will suggest that you clean the sensor while the camera is off and with the goal for you to do that is for the screen to be brought or up in the vacant position.
    The screen would stand out something else

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.